New member with LCP Max Issues

Help Support Ruger Forum:

Joined
Mar 12, 2024
Messages
3
Location
Portland, Maine
New member from Maine. I found this group after having issues with a brand new LCP Max. I sent it back to Ruger after the first trip to the range. I ran 120 rounds Armscor 95 gr FMJ and had 1 FTE, 2 FTF, and the magazine dropped out 3 times while firing. Ruger tech experienced the magazine dropping issue and "fixed it" he also replaced the trigger. I went to the range when I got it back and ran 140 rounds Armscor 95 gr FML through it. Had 2 FTF issues and sent it back to Ruger last week. Got an email yesterday saying the tech ran 100 rounds through it without issue and they sent me a video of it running flawlessly. I'm thinking the cheap ammo I was using is part of the problem. I'm going to the range when I get it back and I'll update this post. From all of the posts I've seen on this site about issues with the LCP Max I believe a made a mistake purchasing this pistol.
 
Joined
Nov 15, 2005
Messages
10,654
Location
Greenville, SC: USA
Noting wrong with practicing with cheap or questionable ammo but then keep the pistol loaded with the best you can find. Actually, one of the most important drills one can have when taking a firearms class is what to do during various malfunctions... and a fail to fire is always the first one... it used to be tap, rack and fire but now it is tap, rack and re-aquire the target.
 

bear007

Bearcat
Joined
Feb 28, 2013
Messages
88
Location
Western PA
Welcome Mainman,

No problems with my Max, I haven't ever shot Armscor ammo in it though. Shot a lot of Rem UMC 95 gr FMJ with zero problems, I was getting it in 300 round buckets.

I traded my LCP2 in for it sometime after it was released for sale and haven't looked back. It is my pocket carry when I can't do IWB.
 

s4s4u

Hunter
Joined
Dec 16, 2006
Messages
2,125
Location
MN, USA
Welcome aboard. Different ammo could fix your problem.

Ya, to base reliability on the results with only one cartridge is folly. You don't have to buy top shelf, but something else.

I handload, and loaded some ammo with Titegroup for the daughter's LCP. The gun would not run, period, the extractor would occasionally leave the fired case halfway in the chamber. I ran some Blazer through it and it ran flawlessly. Sent it back. Got it back. Still wouldn't run that load. I decided to load some with Bullseye, same bullet and case. Gun runs like a Swiss watch. Try different ammo.

Pic of failure:

zLuXDHa.jpg
 
Top