P95dc, not firing double action

Help Support Ruger Forum:

CBH

Bearcat
Joined
Jan 25, 2009
Messages
23
I believe I disconnected something when I was cleaning the gun. I took the trigger out to clean crud from it and the area is sits in. Any ideas (other than quitting gunsmithing) would be appreciated. The gun fires SA, and is accurate.
 

TruthNotRelative

Single-Sixer
Joined
May 12, 2005
Messages
260
The DA pull involves the Trigger Bar and the Hammer, might wanna see if the Trigger Bar is seated in there properly.
 

CBH

Bearcat
Joined
Jan 25, 2009
Messages
23
How does the trigger bar connect to the hammer? I think that is where my problem lies....other than I took it apart to begin with, :roll: .
 

TruthNotRelative

Single-Sixer
Joined
May 12, 2005
Messages
260
Let's do a test.

Remove the slide from the pistol, then hold the receiver(frame) and pull the trigger. If the trigger moves freely without engaging the hammer, pull back slightly on the hammer until you hear a click. If it clicks, the trigger-bar has engaged the hammer. If NOTHING happens, push down on the part of the Trigger-bar that peaks out the side of the frame. Is it "spongy"? Does it move down about an eighth of an in and spring back up?

Beyond this, it's real hard to say without seeing the pistol. If you don't solve it after this post, remove the slide and take pics of the trigger-bar etc. in the frame and post them so that we can take a look.
 

TruthNotRelative

Single-Sixer
Joined
May 12, 2005
Messages
260
When your 95 is cocked, the sear engages the hammer (The click you hear when you manually cock the hammer), and when you pull the trigger in SA mode, the trigger-bar is engaged with the sear and the sear "drops" the hammer. When you pull the trigger in DA mode, the very rear of the Trigger-bar engages the hammer. And, as far as my knowledge, in DA mode the sear never engages the hammer except when the slide is "blown" back and then the sear engages the hammer and hence the hammer is then cocked thereafter with every pull of the trigger until the mag' is empty. I hope I got that all right.
 

CBH

Bearcat
Joined
Jan 25, 2009
Messages
23
Check to make sure that the Trigger Bar spring is seated in the hole in the frame al the way


I do believe this is the problem, going to work on it as soon as I can find my glasses. Thank you.
 

CBH

Bearcat
Joined
Jan 25, 2009
Messages
23
Regretfully, no. I can't figure it out, other than sometimes the trigger does not re-set itself. It does fire, I shot it again today. I am disenchanted with it, to say the least, and will go tomorrow to check on shipping it back to Ruger in AZ for a check-up...or I will sell or trade it rather than bother with shipping and waiting. Thanks for your help I do appreciate it.
 

TruthNotRelative

Single-Sixer
Joined
May 12, 2005
Messages
260
If I understand correctly, you said that the problem arose when you cleaned it and removed the trigger etc.. Why would you want to get rid of it simply because of this issue? I wish that I had it in front of me, I'm sure it's simple. Taking down the receiver really isn't that difficult (I'm not recommending that you do that being inexperienced). In any case, be patient and have someone look at it for you. BTW, why don't you take some pics for me and post them? It sounds like it could be the trigger bar spring. Did you check that out real good?
 

donavon

Bearcat
Joined
Feb 12, 2009
Messages
1
I have the p89 that is having the same problem. I have't taken any of the trigger mechanism apart. The gun fires every time SA but DA it gives a lite primer hit maybe once every six or seven shots. It is not the ammo or primers.With an empty gun pointed up and a pencil in the barrel,eraser end down, the pencil will eject 2 to 3 feet every tme the trigger is pulled.But when the lite hit occurs the pencil pops up maybe 2 inches. Any ones advice is welcome. Stumped.
 

CBH

Bearcat
Joined
Jan 25, 2009
Messages
23
Anybody got a stainless snubbie Security, Service, Speed Six revolver they want to swap for the P95dc?
 

TruthNotRelative

Single-Sixer
Joined
May 12, 2005
Messages
260
You're a "strange" fella (NO OFFENSE). You still haven't explained why you are "disenchanted" with a pistol that you yourself said you "broke". ?

I don't believe you told us how long you've had the pistol. Did you buy it new? Used? ?
 

TruthNotRelative

Single-Sixer
Joined
May 12, 2005
Messages
260
Question: Have you ever taken the trigger or other parts out before? If not, and this is the 1st time that this has happened to this pistol, then I think you might be a little impatient. Has it been a good pistol otherwise?
 

CBH

Bearcat
Joined
Jan 25, 2009
Messages
23
I gave up on the P95dc and shipped it off to Ruger in AZ, to the attention of the technician who was so kind and helpful over the phone. Hopefully I will have it back in three or four weeks.
 
A

Anonymous

did it come back from repairs and with an explaination? I have the same issue.
 

CBH

Bearcat
Joined
Jan 25, 2009
Messages
23
luvall, Ruger in Prescott, AZ did not receive/log-in my P95dc until 4/1/9. I was told then to expect a minimum of four to six weeks before the techs would get to it. I believe I am suposed to receive a written explanation of the problems along with an estimate, however, I told them to phone me as I did not have time to wait on a letter.

I will notify you a.s.a.p. when I hear from Ruger.
 

COFFEE POT

Bearcat
Joined
Mar 16, 2003
Messages
54
donavon":2qngbiy2 said:
I have the p89 that is having the same problem. I have't taken any of the trigger mechanism apart. The gun fires every time SA but DA it gives a lite primer hit maybe once every six or seven shots. It is not the ammo or primers.With an empty gun pointed up and a pencil in the barrel,eraser end down, the pencil will eject 2 to 3 feet every tme the trigger is pulled.But when the lite hit occurs the pencil pops up maybe 2 inches. Any ones advice is welcome. Stumped.
That last description is the key. It sounds as though the firing pin block may not be getting out of the way all the time. There is less hammer travel in DA than SA. therefore less hammer energy. The timing may also be off. Try this. Remove the rear sight, from left to right. Check to see if there is a burr on either the firing pin block or the firing pin. If there is, remove said burr. you may have to remove the firing pin if the burr is on it. I can walk you through that if necessary. I don't like to say it, but this situation really should be handled by the factory. You may need a higher trigger bar. I'd call them and see if they'll cover it under warranty and send you shipping box and call tag. At least the call tag. Shipping is expensive these days.
 

Latest posts

Top