Mark III Reassembly Problem with Mainspring housing

Help Support Ruger Forum:

jnorcal

Bearcat
Joined
Mar 6, 2010
Messages
2
First time reassembling a new Mark III, and I cannot close the mainspring housing.

I am able to insert the mainspring housing bolt stop pin until it "clicks" fully in place. And, I see the rounded part of the bolt stop pin above the top of the rear receiver hole.

But, when I close the mainspring housing, it pulls the bolt stop pin out of place and I am unable to close the mainspring housing.

Anybody have any ideas on what I'm doing wrong?

Thanks.
 

rooger

Single-Sixer
Joined
Jul 9, 2009
Messages
144
Location
Auburn, CA
these tips from that chart are crucial:
"...there should be some spring tension (you can press it in and it will go flush but pop back up when you release pressure) just before it goes flush with the grip (second pic). If it goes completely flush with the grip(third pic) the hammer strut is not engaging the spring housing correctly."
 

louiethelump

Buckeye
Joined
Oct 17, 2005
Messages
1,884
Location
Webster, Florida
You have to remove the magazine to get it to close on the MKIII. You have to put the magazine in and out to get it all together, but after you put the mag in and move the hammer forward, you have to take the mag back out as it interferes with the closing of the latch on the mainspring housing.

Louie
 

jnorcal

Bearcat
Joined
Mar 6, 2010
Messages
2
Thanks for the ideas. They worked!

The trick was being able to move the hammer out of the way after inserting the bolt.

This is done by loading an empty magazine, and then pushing the hammer forward with a dowel while pulling the trigger.

This gets the hammer out of the way. It is then quite easy to insert and close the mainspring housing.

Thanks.
 
Top