Ruger Charger

Help Support Ruger Forum:

A

Anonymous

Bought a Charger model in late January. Got the stainless, too, love the look. And it shoots well IF it can chamber a round. But it stovepipes an average two rounds out of a magazine of ten. This varies with the ammo--I have used everything from el cheapo up to the two brands they use at the factory to test them, and up to 1450 FPS -- but it remains entirely unreliable. I have also checked the scope rail. It was installed when I got the gun (by the shop, I suppose, though why, I have no idea). The screws did NOT extend into the chamber.

I have fired (slowly and painfully) more than s thousand rounds through it by now. There is no improvement.

What can I do about this? I am not thrilled to be having to check the bolt every shot to see if it is forward or if there is a smashed cartridge case stuck sideways in there (and, usually, a damaged live round behind it).
 

contender

Ruger Guru
Joined
Sep 18, 2002
Messages
21,211
Location
Lake Lure NC USA
Welcome to the Forum!
The Charger has the basic 10/22 action,, and it sounds like you may be experiencing the need of a little tweaking of the extractor or the ejector.
Take it apart,, clean it thourghly, and under magnification,, check the extractor & ejector. If there are any burrs,, CAREFULLY file them away.
You can also add an aftermarket extractor & it can cure a lot of the occasional ills of the 10/22 action design. Volquartsen makes excellent replacement parts!
 

mike7mm08

Buckeye
Joined
Mar 14, 2005
Messages
1,709
Location
Milwaukee Wisconsin
My charger was a little finicky about feeding at first. A total disassembly and cleaning fixed my problems. I am not certain if the stainless ones have a painted receiver. The "blued" charger is painted including the inside of the receiver. On mine I had all kinds of paint flakes gumming up the action works. Once all that was cleaned out no problems at all. Another thing you can try which has helped me with some new semiauto 22 feeding problems is high velocity ammo. Might want to try breaking things in with some stingers.
 

PAVTXER

Single-Sixer
Joined
Jan 20, 2010
Messages
342
Location
Pittsburgh Pa
I agree... give it a good cleaning and lube (which I do to all new or used guns I purchase before use). I just added the Archangel Kit to my charger and love it..... I'm sure you will to.




picture.php
 

Bigfoot62

Bearcat
Joined
Jul 4, 2007
Messages
75
Location
West Central LA
Yep, clean it first. Like Mike said, you may have paint in the action.
Then, if no improvement, try a new magazine. (everybody needs spare mags anyway) :wink:
 
Joined
Nov 15, 2005
Messages
8,821
Location
Greenville, SC: USA
I would assume the charger came with two mags.... and the problem occurs with either mag.

obviously something is screwy in there... if you know of anyone with another charger or even a 10/22 I would change out the bolt and see if this fixes the problem.. then you know where to look.

Probably the extractor as Contender mentioned above.
 

Bigfoot62

Bearcat
Joined
Jul 4, 2007
Messages
75
Location
West Central LA
blume357":3g6z3ir9 said:
I would assume the charger came with two mags.... and the problem occurs with either mag.

obviously something is screwy in there... if you know of anyone with another charger or even a 10/22 I would change out the bolt and see if this fixes the problem.. then you know where to look.

Probably the extractor as Contender mentioned above.

:?: Huh?
I've never seen a Charger that "came with two mags." Mine came with one.

I was suggesting a simple magazine swap before he started tearing things up and changing parts.
 
Joined
Nov 15, 2005
Messages
8,821
Location
Greenville, SC: USA
well if he's only got one mag then I agree.... I'd for sure try a different mag... possibly polish the chamber a little ... then go from there.

as I said before, nice thing is with a little work it should be easy to fix.

I changed out trigger groups on two 10/22s today. Put my very good one on my little tactical rifle with the 16" Green Mountain barrel with tech sights....
 

stevek44

Bearcat
Joined
Apr 29, 2008
Messages
45
Location
North Mankato, Minnesota
I purchased a new Charger a while back and have put around 500 rounds through it without a glitch. I used the stock magazine and two Butler Creek 25rd mags. I gave it a thorough cleaning before I ever fired it, as I do all my new guns. I guess I would recommend a good cleaning, and possibly try a different magazine.

SteveK44..
 

Pat-inCO

Hawkeye
Joined
Oct 17, 2009
Messages
5,850
Location
In the AZ oven (Phoenix basin)
blume357":1gq3zxka said:
I guess the original poster was not really too interested in getting his Charger to work right.... they've not been back since post #1.

True.

I guess I was really lucky then, because my new Charger has been a gem.
I put a http://www.midwayusa.com/viewProduct/?productnumber=179627 TruGlo on it and it took at least five or eight shots to get it adjusted to shoot dead center of the target.

After that it has been amazingly accurate, shooting nickel size groups at twenty five yards.

Ungainly as all get out, but FUN to shoot.

Almost forgot. The trigger pull is better than the standard 10/22.
 

Latest posts

Top